同花顺三线主升指标公式

时间:2019-06-25 05:42:19

X_1:=CLOSE*VOL;
X_2:=EMA((EMA(X_1,3)/EMA(VOL,3)+EMA(X_1,6)/EMA(VOL,6)+EMA(X_1,12)/EMA(VOL,12)+EMA(X_1,24)/EMA(VOL,24))/4,13);
X_3:=EMA(CLOSE,9);
MF1:EMA(X_3*1.11,5),colormagenta,LINETHICK1;
X_4:=CLOSE*VOL;
X_5:=EMA((EXPMA(X_4,3)/EXPMA(VOL,3)+EXPMA(X_4,6)/EXPMA(VOL,6)+EXPMA(X_4,12)/EXPMA(VOL,12)+EXPMA(X_4,24)/EXPMA(VOL,24))/4,13);
X_6:=1.13*X_5;
X_7:=MA(HIGH,30)*(1+15/100);
X_8:=CROSS(CLOSE,MF1) AND CLOSE>=REF(CLOSE,1)*1.048;
DRAWICON(CROSS(CLOSE,MF1),LOW*0.96,26);
DRAWICON(CROSS(CLOSE,MF1),LOW*0.92,13);
X_9:=CROSS(CLOSE,X_6) AND CLOSE>=REF(CLOSE,1)*1.048;
X_10:=CROSS(CLOSE,X_7) AND CLOSE>=REF(CLOSE,1)*1.048;
X_11:=MA(CLOSE,20);
STICKLINE(CLOSE/REF(CLOSE,1)>=1.09,OPEN,CLOSE,2,0),coloryellow;
STICKLINE((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.049 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<0.098,CLOSE,OPEN,2,0),colormagenta;
X_12:=MA(CLOSE,5);
X_13:=MA(CLOSE,8);
X_14:=MA(CLOSE,13);
X_15:=MA(CLOSE,21);
X_16:=MA(CLOSE,34);
X_17:=MA(CLOSE,50);
X_18:=OPEN<=X_12 AND CLOSE>X_12;
X_19:=OPEN<=X_13 AND CLOSE>X_13;
X_20:=OPEN<=X_14 AND CLOSE>X_14;
X_21:=OPEN<=X_15 AND CLOSE>X_15;
X_22:=OPEN<=X_16 AND CLOSE>X_16;
X_23:=OPEN<=X_17 AND CLOSE>X_17;
X_24:=X_18+X_19+X_20+X_21+X_22+X_23>4;
X_25:=CLOSE>OPEN AND CLOSE>REF(CLOSE,1)*1.03 AND CLOSE=HIGH AND X_24;
DRAWICON(X_25,LOW*0.98,30);
STICKLINE(X_25,CLOSE,OPEN,2,0),coloryellow;
STICKLINE(X_25,CLOSE,OPEN,1.5,0),colorred;
STICKLINE(X_25,CLOSE,LOW,0.02,0),colorblack;
STICKLINE(X_25,OPEN,LOW,0,0),colorgreen;

通达信公式源码安装方法步骤图解:点这里查看指标公式安装方法